All Collections
Telehealth Support
What web browsers are supported?
What web browsers are supported?
Updated over a week ago

You can join our video calls on any of the latest version of popular web-browsers. Check your version here.

The minimum browser requirements include:

  • Google Chrome Version 82+ (Windows, Android, MacOS)

  • Apple Safari Version 12+ (MacOS, iOS)

  • Firefox Version 75+ (Windows, Android, MacOS)

  • Microsoft Edge Version 82+ (Windows MacOS)

  • Microsoft Edge Version 44+

Did this answer your question?